Jump to content
Orca Cola Championship
Sign in to follow this  
danton

Adding Images to Posts

Recommended Posts

I can't seem to add images to posts anymore. When I select the "Insert Image from url" option and paste an image link into the box it just goes red and doesn't let me do it. I've tried this with various different image hosting options and it's always the same. I'm on Chrome on a Mac.

 

Is this a known issue and is there another way to add images to a post if so?

Share this post


Link to post
Share on other sites

8AdxM7p.jpg

 

I just posted this picture of myself from imgur.

upload it then select get share links and pick the BBCode

Share this post


Link to post
Share on other sites

NO235nZ.jpg

 

Naw.

 

Are you sure you are using direct links, i.e. ones that end with an image filename (.gif, .png, .jpg, etc.)? I just paste one of those in a message and it adds it.

Share this post


Link to post
Share on other sites

Yes I am trying direct image links with the correct extensions - worked as a web developer for over 15 years! ;)

Copying and pasting links doesn't work for me either. It looks like it might be an issue that affects Chrome on OSX and iOS in particular, but would be interesting to know if it works for someone else using it on either of those platforms.

 

Where is the option for uploading images on the forum?

Share this post


Link to post
Share on other sites

 

3 minutes ago, danton said:

worked as a web developer for over 15 years! ;)

 

 

Then you know it's best to assume people haven't tried the most obvious solutions. :P 

 

Uploads are not possible; I turned them off when the forum where giving us issues and never had a reason to turn them back on. Now that we have someone who actually knows what they're doing helping us with the forums, they may be able to look into it. Not my table anymore. :cool:

Share this post


Link to post
Share on other sites

Just tried it on Safari and get the same issue, so maybe it's a Mac only problem. Could be that a forum plugin was updated recently or something like that, because it used to work for me.

Share this post


Link to post
Share on other sites

Might it be tied to usergroup rights? Greens and teals are clearly OK but perhaps not blue rabble like Danton?

Share this post


Link to post
Share on other sites
Awards

Sure, here is a Public Dropbox image link I was trying to add:

 

https://www.dropbox.com/s/5gpuydzm8ubdyc2/Photo 06-12-2018%2C 18 30 24.jpg?dl=0

 

I also tried removing the parameter from the end of the link so that it ends in .jpg but it made no difference. Tried adding link from imgur and google drive too, but couldn't get those to work either.

Share this post


Link to post
Share on other sites

It was just af copy of the webadress on the image done from a computer in Chrome, so it must be something with the Mac part. 

Edited by Jester77

Share this post


Link to post
Share on other sites

1 hour ago, danton said:

Sure, here is a Public Dropbox image link I was trying to add:

 

https://www.dropbox.com/s/5gpuydzm8ubdyc2/Photo 06-12-2018%2C 18 30 24.jpg?dl=0

 

I also tried removing the parameter from the end of the link so that it ends in .jpg but it made no difference. Tried adding link from imgur and google drive too, but couldn't get those to work either.

 

Inserting the image automatically works for me PC/Chrome if I paste the full address. The forum automatically pastes the image and then I get a message asking if I want the image or if I want to just paste the link instead.

 

(https://uca01f76cbdc545d5134db064295.previews.dropboxusercontent.com/p/thumb/AASORno9j047hkNHXsEYlA1JWP6wT55cCoYAn7TtnXlcqKEO7e0cuJQ-ugHOTvAqQQ0qz3LTXHncQ7cW4lwJHak4EbUbHNFRAuqR0GzpjC6IQ7RHC2FDTjoAXvsjsm0250oOZv6qnn7SSFzYs82mSDhWGOAeHd4JSEWzZsSL_R-JKcWGeEDz8XXXx9k17L6OHdGi1fer5QP2jOUhjm95BRUKdoQAis8qxfg8dqA_CUKYyA/p.jpeg?size=2048x1536&size_mode=3)

 

I'm assuming you also used the image's address (you get when you right click and image and choose "copy image address")?

 

EDIT:

 

Did find this:

https://discuss.codecademy.com/t/get-an-image-url-using-a-mac/61965

 

Quote

To get the URL (address) of an image on the web using Safari or Chrome on a Mac:

  1. Hold down the Control key on your keyboard and then click on the image.

  2. Choose the "Copy Image Address" option from the pop-up menu.

  3. Go back to the Codecademy editor in your browser and position the cursor to where you want to insert the image URL.

  4. Choose Edit > Paste or use the keyboard shortcut CMD+V (hold down the Command key and then press the V key), to paste the image URL into your code.

If you're using Chrome on a Mac, make sure you're not using Version 51 as there was a bug which prevented some people being able to copy and paste the image URL from Chrome to other apps. The current version, Version 53, appears to be fine.

 

Edited by C2MC

Share this post


Link to post
Share on other sites

1 hour ago, danton said:

Sure, here is a Public Dropbox image link I was trying to add:

 

https://www.dropbox.com/s/5gpuydzm8ubdyc2/Photo 06-12-2018%2C 18 30 24.jpg?dl=0

 

I also tried removing the parameter from the end of the link so that it ends in .jpg but it made no difference. Tried adding link from imgur and google drive too, but couldn't get those to work either.

 

Dropbox doesn't allow hotlinking anymore, so there's your problem.

Share this post


Link to post
Share on other sites

3 minutes ago, Rymdkejsaren said:

 

Dropbox doesn't allow hotlinking anymore, so there's your problem.

 

It works for me and Jester, but when you "open" the file it's a download instead of an online image. Danton also mentions it's not working for imgur and the likes. My guess is either a Mac + Chrome issue somewhere or the problem is situated in between the monitor and the chair.

Share this post


Link to post
Share on other sites

43 minutes ago, C2MC said:

I'm assuming you also used the image's address (you get when you right click and image and choose "copy image address")?

 

p.jpeg?size=1280x960&size_mode=3

 

Got it to work! The Copy Dropbox link from the finder does not work, but right clicking on the image on the Dropbox website did!

 

Thanks to everyone for the Tech Support!! Got there in the end! :wacko:

Share this post


Link to post
Share on other sites

Is there supposed to be an image in that post? :(

 

I swear Dropbox turned of all direct access to the public folder (they even sent out a mail about it). I used to run all images from there but had to switch to Imgur because I couldn't get it to work however I tried.

Share this post


Link to post
Share on other sites

Just now, danton said:

You can't see it? It appears for me... :o

 

Did you resize it using the forum options? That bugs out sometimes. I see this:

PezifRZ.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Support the OCC

    Donate Sidebar by DevFuse
×
×
  • Create New...